
The Text Track in QuickTime is being redeployed to provide new and interesting features for Web masters. An
embedded URL can be placed in a QuickTime file as an additional text track. It can be made to send a URL to a
specific frame in the web page when a particular point in time is reached. In this way you can have an additional
source of information that is displayed about a character in the movie that is playing in a nearby frame. An example of
this might be where a music video about your favorite band is playing, and background information about the artist in
the frame can be displayed while they are in the movie frames. Information about concert tickets or where to purchase
the album might be displayed if it is a trailer or advertisement. This can be also be used with QuickTime media alone.
Even sprite movies can have a URL associated with them so that clicking on a particular sprite or area of the movie
takes the user to the specified URL. In other words, this capability is available without a browser launched and present.

Creating a Text Track:

1.  Using any text editing application, enter the text desired and save as a text file
to the hard disk. Windows users can use WordPad while Mac OS users can use
SimpleText. Although, any word processing applicaion will work.

2.  Launch QuickTime Player and select 'Import' from the File menu option. Where
it says 'Save Converted File as:' save the file with the .mov extension. Simply
launch the movie to see the results.

Features:
Creating a Text Track
Creating HREF Tracks
Creating Chapter Tracks

Functionality:
Importing a Text Track
Exporting a Text Track
Extracting a Text Track
Deleting a Text Track
Searching A Text Track
Enabling a Text Track

Modifying:
Using Time Stamps
Using Text Descriptors

3.  By exporting the text track while in QuickTime Player, you will be able to modify the text descriptors and time
stamps to alter the behavior of the track.
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Adding HREF Text Tracks with QuickTime Player

Introduction

This workshop shows you how to take a movie and create and add a special text track -
an HREFTrack - that loads additional information into a frame at specific times during
the movie.

You can also use this workshop to learn how to create a regular, visible text track.
Regular text tracks can be creatively formatted, so after you've reviewed this document
you'll want to look at Text Descriptors and Time Stamps for information on how to style
your text tracks.

But first, look at an example of the kind of page this workshop will show you how to
create.

You may also want to look at the syntax for the HREFTrack.

Create a base text track

The first step is to create a text-descriptor document with a start and end time code for your movie.
The best way to do this is to let QuickTime Player do most of the work for you. Follow these steps:

Using Simple Text (or WordPad on the PC), create a text file with anything in it. In this
example, the file contains the words "some text"

1.  

Import the file into QuickTime Player. It will be converted into a short movie.

Text imported into a movie by QuickTime Player

2.  

Copy the first frame of the movie to the clipboard (Command-C on Mac, Control-C on
Windows)

3.  

Open the movie you plan on adding the text track to.4.  

Go to the beginning of the movie and choose Select All from the Edit menu (Command-A on
Mac, Control-A on Windows).

5.  

Hold down the Shift and Option keys (Shift-ALT on the PC) and pull down the Edit menu in
QuickTime Player. Select Add Scaled. (If Add Scaled does not appear in the menu, try again.
Make sure you are holding both keys down before you click on the menu).

6.  

Chose Export... from the file menu and select Text to Text in the popup in the dialog.7.  
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VERY IMPORTANT: Click the Options button in the dialog and click the Save Text,
Descriptors, and Time option. Now select 30 from the pop-up menu next to Show Fractions of
a Seconds as 1/__. Finally, click OK to dismiss the dialog.

The export options dialog for export to text

8.  

Click the Save button and choose a name for the file.9.  

Editing the Text Descriptor File

Exporting text from QuickTime Player using the Save Text, Descriptors, and Time
option creates a text-descriptor document. You will need to edit to insert your own
interesting times and actions that should occur at those times. (To help you understand
the document you're about to edit, you may want to review information at the beginning
of Text Descriptors and Time Stamps.)

The next step is to edit the file and add new timestamps and instructions. Follow these
steps:

Using Simple Text (or WordPad on the PC), open the text file you just saved. It
should look something like this:

{QTtext} {font:Geneva} {plain} {size:12}
{textColor: 65535, 65535,65535}
{backColor: 0, 0, 0} {justify:center}
{timeScale:30}
{width:160} {height:16}
{timeStamps:absolute} {language:0}
[00:00:00.00]
Some text
[00:00:01.00]
[00:00:30.28]

1.  
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You can delete the two lines:
Some text
[00:00:01.00]

What you are going to do next is use QuickTime Player to determine the times
when you want things to happen and use Simple Text (or WordPad on the PC) to
enter those times into the text file, in between the start and ending time codes.

2.  

Return to QuickTime Player and play or scroll the movie until you locate the first
frame that you want to attach a command to. Choose Get Info and then the
Movie/Time dialog:

The Movie/Time panel of the Get Info dialog

Note the time in Current Time (00:00:22.01 in this case).

3.  

Return to Simple Text and copy this time on a new line below the first time code
line ( [00:00:00.00] ). Make sure you enclose the time with square brackets.
The end of your file should now look like this:

[00:00:00.00]
[00:00:22.01] (or whatever number you copied)
[00:00:30.28] (or whatever the last time in your movie is)

4.  

The syntax to specify loading a new file at a particular time into a frame is:
A<newcontent>  T<theframename>

The A signifies to the plugin that the content that follows is to be loaded
automatically. The T indicates that rather than just replacing the movie with the
new content, the content should be loaded into a new Target frame, which follows
it. So you will also need to know the name of the frame (TEXT in this example)
and names of the HTML files you want to load into the frame at that point
(part1.htm, part2.htm and part3.htm in this example). In the example, the first file
should be loaded into the frame right at the beginning of the movie, and the
second file to be loaded after the movie reaches [00:00:06.09]. To do this, add the
syntax for loading the frame right after the time code that you want to the action

5.  
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to happen at. The first two time code lines are now:

[00:00:00.00] A<part1.htm> T<text>
[00:00:06.09] A<part2.htm> T<text>  
Note:There should be no space between the "A" and the "<" or the "T" and the
"<"
Continue in this fashion until you have found all the key time points in
QuickTime Player and copied them into the text file, adding the commands next
to each time.

The finished file might look like this:

{QTtext} {font:Geneva}
{plain} {size:9}
{timeScale:30}
{width:160} {height:32}
{timeStamps:absolute} {language:0}
[00:00:00.00]
A<part1.htm> T<text>
[00:00:06.09]
A<part2.htm> T<text>
[00:00:20.19]
A<part3.htm> T<text>
[00:00:30.28]

Note: The last line of the file must be an ending time code followed by a carriage
return (blank line). If not, your movie will not display properly.

Save your work. You're now ready for the next step.

6.  

Creating the HREF Track

First, assuming you still have QuickTime Player open, the movie you are working on
will still have the text track you added in the previous section. Since that's not necessary
anymore, you should delete it.

Select Delete Tracks from the Edit Menu. In the dialog that is displayed, click on the
Text Track (if there is more than one Text Track, select the last one) and click the Delete
button.
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The Delete Track dialog

The next step is to take the text file we just created and add it to the movie. This is
similar to how we created the first text track:

Import the text file into QuickTime Player. It will be converted into a movie.1.  
Go to the beginning of the movie and choose Select All from the File menu
(Command-A)

2.  

Copy the entire movie to the clipboard (Command-C)3.  
Select the movie you plan on adding the text track to.4.  
Go to the beginning of the movie and choose Select All from the file menu
(Command-A)

5.  

Hold down the Option key (ALT-CTL on the PC) and pull down the Edit menu in
QuickTime Player. Select Add. (When we first created the text track, we were
careful to add it to the movie scaled to last the movie's entire duration. Since we
are sure the durations match, this time we just need to add the text track movie to
the movie.)

6.  

Renaming the Text Track

Next, we need to rename the text track. The QuickTime plugin looks for a track called
HREFTrack to take control information from, but by default a text track is just called
Text Track.

To change the name of the text track, select the Text Track/General panel of the Get
Info panel and click the Change name button. Type "HREFTrack", click OK, and save
your work.
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The Track name dialog of the Text Track/General Get Info dialog

 

 

Hiding the HREFTrack

Finally, we want to hide the HREF track it so it is not visible to the user.

To do this, choose Enable Tracks from the Edit menu. Click the ON button to the left of
the Text Track to turn it off. This hides the track from the user but does not prevent it
from being used.

The Enable Tracks dialog

Creating the Frame HTML

Since this example displays the narrative text to a movie in a separate frame, the HTML
code for the frames is defined in the main page. Covering frame HTML is beyond the
scope of this document, so we suggest you look at Netscape's "Frame Basics"
documentation.
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For those of you who are familiar with frames (or simply interested), here is the main
frameset for the frames used in the example:

<HTML><HEAD>
<TITLE>Auto-URL Demo</TITLE>
</HEAD>

<FRAMESET Rows="120,220,*" FRAMEBORDER="0"
BORDER=0 >

<NOFRAMES> <BODY BGCOLOR="#FFFFFF">

<P>This page is designed to be viewed by a browser
which supports
Netscape's Frames extension. This text will be
shown by browsers
which do not support the Frames extension.</P>

</BODY>
</NOFRAMES>
    <FRAME SRC="autocont.htm" NAME="contents"
NORESIZE SCROLLING="NO">
  <FRAMESET Cols="260,*" FRAMEBORDER="0" BORDER=0
> <BGCOLOR="#FFFFFF">
     <FRAME SRC="autopres.htm" NAME="movie"
NORESIZE SCROLLING="NO">
     <FRAME SRC="autotext.htm" NAME="text"
NORESIZE SCROLLING="NO">   </FRAMESET>
   <FRAME SRC="autodesc.htm" NAME="contents" >
</FRAMESET>
</BODY>
</HTML>

A few things to notice in the example: we use the NORESIZE and SCROLLING="NO"
tags for the frame in which the movie plays so that no scrollbar is displayed and to
prevent the user from resizing the frame. We set the ROWS= and COLS= options of the
frameset to make sure that the movie has enough room in the frame to display
completely.

Creating the HTML for the Movie Frame

The HTML for the frame with the movie inside it is straightforward:

<HTML>
<HEAD>
<TITLE>Untitled</TITLE>
</HEAD>
<BODY BGCOLOR="#FFFFFF">
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<EMBED SRC="present.mov"
CONTROLLER=true BGCOLOR="#FFFFFF" WIDTH=240
HEIGHT=196
autostart=TRUE>
</BODY>
</HTML>

This simply embeds the movie on a white background and tells it to start automatically.
(For more information on the HTML code used here, refer to the QuickTime Embed
documentation .)

Creating the HTML for the Targeted Frame

The targeted frame - or frames - are the frames that are referenced in a movie's
HREFTRACK. The HTML for these frames can contain anything; the important things
are that:

A file with the correct name exists for each file referenced in the HREFTrack,●   

These files are in the correct place relative to the movie that refers to them. For
example, if the HREF track specifies a file "../foo.html", then foo.html needs to be
located one level up from the movie in the directory structure.

●   
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Chapter Tracks add additional functional in QuickTime movies by allowing users to advance to a particular time in the
movie. This is done by providing a pop-up menu in the movie controller when placed on the web.

Creating a Chapter Track:

1.  To create a Chapter Track, content creators will need to begin with a text
editor and determine what the chapter list will be. For this example, using the
words internet, cd-rom, dvd, and videotape creates a Chapter Track with the
following chapter lists:

NOTE: The chapter list is determined by placing a charage return (enter or return)
after each text entry in the text document.

2.  Save the text document to the hard disk and import this document by choosing
'Import...' from the 'File' menu option in QuickTime Player. When prompted, to
'Convert...' the document, save the text file as a QuickTime movie. The movie
should now be open in a seperate window.

Features:
Creating a Text Track
Creating HREF Tracks
Creating Chapter Tracks

Functionality:
Importing a Text Track
Exporting a Text Track
Extracting a Text Track
Deleting a Text Track
Searching A Text Track
Enabling a Text Track

Modifying:
Using Time Stamps
Using Text Descriptors

3.  Choose 'Select All' from the 'Edit' menu option and copy the data to the clipboard by choosing 'Copy' from the 'Edit'
menu option.

4.  Open the movie you want to add the Chapter Track to and select 'Add Scaled' from the 'Edit' menu option. To invoke
'Add Scaled,' Mac OS users will need to hold down 'Option + Shift' while accessing the 'Edit' menu option. Windows users
will need to hold down 'Ctrl + Alt + Shift' while accessing the 'Edit' menu option.

5.  To set the text track to a chapter track, choose 'Get Info' from the 'Movie' menu option and select 'Text Track' in the left
pop-up menu and 'Set as Chapter Track' in the right pop-up menu. Choose the button for 'Set Chapter Owner Track' which
prompts a dialog box to select which track the Chapter Track is assigned to. Select a track and close the 'Get Info' panel.

6.  The Chapter Track is now invoked and present in the controll bar. However, the Text Track is still present and will need
to be disabled. Refer to the side bar on how to disable a Text Track. Do not delete the Text Track as this action will delete
the Chapter Track.

7.  Save the movie and your done.
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Here you can specify basic text attributes such as font, font size, font alignment, font style, font color, and background
color. The text track width and height can also be set here as well as other characterisitcs such as Anti-Alias and Drop
Shadow.

Importing a Text File:

1.  Launch QuickTime Player and select 'Import' from the File menu option.
Select the 'Options...' button which will produce the following dialog box:

Features:
Creating a Text Track
Creating HREF Tracks
Creating Chapter Tracks

Functionality:
Importing a Text Track
Exporting a Text Track
Extracting a Text Track
Deleting a Text Track
Searching A Text Track
Enabling a Text Track

Modifying:
Using Time Stamps
Using Text Descriptors

2.  Basic text attributes can be determined here, such as font, size, alignment, and style. You can also determine the width,
height, text color and background color.

3.  Click 'OK.' Enter a file name with the .mov extension where it says, 'Save Converted File as:'

4.  By exporting the text track while in QuickTime Player, you will be able to modify the text descriptors and time stamps
to alter the behavior of the track.
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Here you can specify basic text attributes such as font, font size, font alignment, font style, font color, and background
color. The text track width and height can also be set here as well as other characterisitcs such as Anti-Alias and Drop
Shadow.

1.  To make additional changes to the timestamps and textdescriptors, simply
export the text track as 'Text to text' in the 'Export' pop up menu. Select the
'Options...' button which will produce the following dialog box:

Features:
Creating a Text Track
Creating HREF Tracks
Creating Chapter Tracks

Functionality:
Importing a Text Track
Exporting a Text Track
Extracting a Text Track
Deleting a Text Track
Searching A Text Track
Enabling a Text Track

Modifying:
Using Time Stamps
Using Text Descriptors

3.  Specifies if the timeStamps that follow are absolute or relative. {timestamps:absolute} the timeStamps show the
time the samples start relative to the beginning of the track. Note that since a track may not start at the beginning of a
movie, this may not always (although it usually does) imply time relative to the start of the movie.
{timeStamps:relative} The timeStamps show the time relative to the previous sample.

4.  Think of this as the fractional part of a second. Ordinarily, people used to thinking about NTSC video probably
think in 30ths of a second, while people used to film may think in 24ths of a second. So NTSC video users would
specify a timescale of 30, while film animators would probably use a timescale of 24.

Apple - Products - QuickTime

http://www.apple.com/quicktime/authoring/exporttext.html (1 of 2) [3/16/2000 2:21:51 PM]

http://www.apple.com/
http://www.apple.com/store/
http://ireview.mac.com/
http://itools.mac.com/WebObjects/Tools
http://icards.mac.com/
http://www.apple.com/quicktime/
http://www.apple.com/support/
http://www.apple.com/quicktime/download/
http://www.apple.com/trailers/
http://www.apple.com/quicktime/qtv/
http://www.apple.com/quicktime/hotpicks/
http://www.apple.com/quicktime/authoring/
http://www.apple.com/macosx/server/qtstreaming.html
http://developer.apple.com/quicktime/


 
Site Map | Search Tips | Options | Keywords

Contact Us | Privacy Notice
Copyright © 2000 Apple Computer, Inc. All rights reserved.

1-800-MY-APPLE

Apple - Products - QuickTime

http://www.apple.com/quicktime/authoring/exporttext.html (2 of 2) [3/16/2000 2:21:51 PM]

http://www.apple.com/find/sitemap.html
http://www.apple.com/find/searchtips.html
http://www.apple.com/find/extsrch.html
http://www.apple.com/find/shortlist.html
http://www.apple.com/hotnews/contact.html"
http://www.apple.com/legal/privacy/
http://www.apple.com/legal/


Extracting tracks (any QuickTime track) pulls the chosen track out of the the movie and copied to a new file. This
operation leaves the original source file intact.

1.  Begin by opening the movie you wish to extract the track from. From
QuickTime Players Edit menu option, select 'Extrack Tracks...' For as many track
types that are present in the movie, each track is extractable as the dialog box here
shows:

Features:
Creating a Text Track
Creating HREF Tracks
Creating Chapter Tracks

Functionality:
Importing a Text Track
Exporting a Text Track
Extracting a Text Track
Deleting a Text Track
Searching A Text Track
Enabling a Text Track

Modifying:
Using Time Stamps
Using Text Descriptors

2.  Simply choose the 'Extract' button and the track will appear in a new window.

3.  If you want to save the extracted file, we recommend choosing 'Make movie self-contained.' Otherwise, the file
will want to reference the source file.

TIP
If the movie has more than one track, you can select multiple tracks to extract which will be extracted into a new
movie. Both Mac OS and Windows users can hold the Shift key down while selecting the desired tracks with the
mouse.
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Deleting tracks is similiar to Extracting tracks. However, unlike extracting tracks, deleting tracks does not create a new
file as extracting tracks does.

1.  Begin by opening the movie you wish to extract the track from. From
QuickTime Players Edit menu option, select 'Delete Tracks...' The following
dialog box will appear:

Features:
Creating a Text Track
Creating HREF Tracks
Creating Chapter Tracks

Functionality:
Importing a Text Track
Exporting a Text Track
Extracting a Text Track
Deleting a Text Track
Searching A Text Track
Enabling a Text Track

Modifying:
Using Time Stamps
Using Text Descriptors

2.  Simply choose the 'Delete' button and the track will disappear.

3.  Deleting the track and saving will not decrease the size of the file. You will need to select 'Save as...' from the File
menu and resave the file.

TIP
If the movie has more than one track, you can select multiple tracks to delete. Both Mac OS and Windows users can
hold the Shift key down while selecting the desired tracks with the mouse.
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QuickTime supports searchable text tracks, so content creators and users can quickly find a particular scene by
searching through its script or annotation text.

Searching a Text Track:

1.  From the Edit menu option, select 'Find...' to begin searching a text track.
This will invoke the following dialog box:

Features:
Creating a Text Track
Creating HREF Tracks
Creating Chapter Tracks

Functionality:
Importing a Text Track
Exporting a Text Track
Extracting a Text Track
Deleting a Text Track
Searching A Text Track
Enabling a Text Track

Modifying:
Using Time Stamps
Using Text Descriptors

2.  Enter the search criteria and click the 'Find' button. You can dictate whether the search advances through the track
towards the end or whether the search goes backward by enabling either the 'Forward' or 'Backward' button.

3.  To find more than one instance of the criteria, chose 'Find Again' from the Edit menu option.
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Unlike deleting and extracting tracks, enabling tracks allows you to turn tracks on or off. This does not effect the file
size or the the integrity of the file. This allows content creators to add more than one audio track for example, and let
users choose the audio track they want to listen to. However, the more tracks added to a movie, the larger the file size.

1.  Begin by opening a movie more than one track. From QuickTime Players Edit
menu option, select 'Enable Tracks...' For as many track types that are present in
the movie, each track can be enabled or disabled as the dialog box here shows:

Features:
Creating a Text Track
Creating HREF Tracks
Creating Chapter Tracks

Functionality:
Importing a Text Track
Exporting a Text Track
Extracting a Text Track
Deleting a Text Track
Searching A Text Track
Enabling a Text Track

Modifying:
Using Time Stamps
Using Text Descriptors

2.  By default, movies generally have all tracks enabled or 'On.' Simply choose the track you wish to enable or disable
and the dialog box will show you whether the track is on or off.

3.  After clicking the 'OK' button, the track will disappear from the movie.

4.  Movies can be saved after enabling or disabling tracks. However the tracks were saved, upon launch of the movie
the tracks will either be on or off.
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Time Stamps

Time Stamps are a convention used in text track files to specify when in the movie the text
that follows the time stamp should be displayed. Time Stamps are either relative or absolute.

Time stamps take the form: [HH:MM:SS:nnn] . Time stamps are always enclosed in
square brackets ("[" and "]"), otherwise QuickTime will ignore them and treat them as regular

text. The first three numbers (HH:MM:SS) are Hours, Minutes, and Seconds, respectively.

The last number (nnn) is a fraction of a second. What the denominator of that fraction is
(30ths, 60ths, 100ths) is determined by the timescale specified in the timescale text descriptor

(described below). If the time scale is 100 or less (but greater than 10), then only two digits
are required for the last number, so the form becomes [HH:MM:SS:nn] . If the time scale

is 10 or less, then only one digits is required for the last number, so the form becomes
[HH:MM:SS:n] .

Time stamps can be relative or absolute, depending on the {timescale:} text descriptor
(see below). Absolute time stamps always refer to the time elapsed since the start of the
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movie, while relative time stamps refer to the time elapsed relative to the previous time stamp.

An example of an absolute time stamp might be [01:10:43:15] . This translates into
"One hour, ten minutes, 43 seconds, and (assuming the timescale has been set to 30) 15/30ths

(1/2) of a second since the beginning of the movie".

An example of a relative time stamp might be [00:01:05:10] . This translates into "One
minute, 5 seconds, and (assuming the timescale has been set to 30) 10/30ths (1/3) of a second

since the last time stamp".
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Text Descriptors

Here is an example of a text track file that illustrates how text descriptors are used to control
the formatting and timing of the text track. (A similar file is used in the Adding Text Tracks

with QuickTime Player Workshop ).

{QTtext} {font:Geneva}
{plain} {size:9}
{timeScale:30}

{width:160} {height:32}
{timeStamps:absolute} {language:0}

[00:00:00.00]
One upon a time in a cubicle not so far away,

[00:00:06.09]
A tired but dedicated engineer

[00:00:20.19]
Worked on through the night...

[00:00:30.28]

As you can see, text descriptors are enclosed in curly braces ( { and } ) and specify the format
of the text that follows. Some are simple one-word commands ( {bold} , for example)

while others take additional information that follows a colon like {font:New York} .
stamps must always start with the {QTtext} descriptor. It can then be followed by any

number of text descriptors, in any order. You can change the format of the text at any time by
inserting a new text descriptor. {plain} , for example, will override a previous setting of

{bold} .

QuickTime Player Pro reads and parses text track files when you import them. QuickTime
Player Pro is not uppercase/lowercase sensitive. But it also does not have a spell checker. If a
spelling error is encountered you may get an error stating that this file cannot be converted.

Q&A:
If a text track file you've created and imported with Movie Player is not displaying the way

you think it should, you may want to try taking out any spaces inside the text descriptors. You
must also ensure that the last line of the file is a contains a time stamp for the end of the

movie. Some versions of QuickTime require that a carriage-return ("Return" on your
keyboard) follows the final time stamp.
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You can make Movie Player generate a basic text descriptor track for you by importing a
short text file into movie player and then re-exporting it as "QuickTime to Text". If you click
the options button in the export dialog and check the "Save text, descriptors, and time" option,
the resulting text file will contain the basic text descriptors and time stamps for a file. (See the
Adding Text Tracks with QuickTime Player Workshop for an example using this technique)

Current Text Descriptors

To understand the example above, and to create your own text descriptor and time stamp files,
you will need to know the text descriptors you have to choose from. Here they are:

{QTtext}

This is required at the start of any file that has descriptors or timeStamps. If this
is not the first thing in the file, the file is assumed to be normal text.

{font: fontname }

The parameter is the name of the font.
Example: {font:Apple Chancery}

This will change all text after the descriptor to the Apple Chancery.

{ fontstyle }

This specifies the style of the text that follows. There are eight valid font styles:

{plain} Plain text.
{bold} Bold text.

{italic} Italic text.
{underline} Underlined text.
{outline} Outlined text.

{shadow} Text with a drop shadow.
{condense} Text with spacing between characters decreased.
{extend} Text with spacing between characters increased.

{justify: alignment }

This specifies the alignment of the text that follows. There are four valid
parameters for justify:

{justify:left} Text will be aligned flush left.
{justify:right} Text will be aligned flush right.
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{justify:center} Text will be centered.
{justify:default} Text will align to whatever the script system has set.

{size: pointsize }

This is the point size of the text (a point is 1/72nd of an inch). {size:18} will
set the point size of text that follows to 18 point.

{textColor: redvalue , greenvalue , bluevalue }

To set the color of the text. There are three numbers between 0 and 65535 that
make up the parameters. These numbers are RGBColor values. The order is red,

green, blue. The values are separated by a comma ','. For example,
{textColor: 0, 0, 65535} is blue text, {textColor: 65535,
32000, 0} is orange (lots of red plus some green equals orange, for

computers anyway!). Spaces before the color values are allowed but not required.

{backColor: redvalue , greenvalue , bluevalue }

This is the same as textColor except that it changes the background color.

{height: texttrackHeightInPixels }

Takes one parameter, the height of the text track in pixels. {height:50} will
set the text track height to 50. A value of zero will set the height to the best fit for

the contents.

{width: texttrackWidthInPixels }

Same as height except a value of zero will set the width to 240 or to that of the
movie if importing into a movie.

{language: languageNumber }

Text tracks can be set to a specific language. The ordinal (numeric) value of the
language is used instead of the actual name. Example: {language:11} sets

the language of the track to Japanese.

{timeStamps: relativeOrAbsolute }

Specifies if the timeStamps that follow are absolute or relative.

{timestamps:absolute} the timeStamps show the time the samples start
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relative to the beginning of the track. Note that since a track may not start at the
beginning of a movie, this may not always (although it usually does) imply time

relative to the start of the movie.

{timeStamps:relative} The timeStamps show the time relative to the
previous sample.

{timeScale: numberPerSecond }

Think of this as the fractional part of a second. Ordinarily, people used to
thinking about NTSC video probably think in 30ths of a second, while people

used to film may think in 24ths of a second. So NTSC video users would specify
a timescale of 30, while film animators would probably use a timescale of 24.

Hint: Movie Player expresses times based on a timescale of 30. If you are
working with Movie Player, you will probably want to use a timescale of 30.

The number of digits in the last value of a timestamp is determined by the
timescale. If {timeScale:10}, then the timestamp for 7.5 seconds would be

' [00:00:07.5] '. But If {timeScale:1000} , the same 7.5 seconds
would be written as ' [00:00:07.500] '. The timeScale cannot go over

1000.

If you like math:   Consider a timeStamp of [00:00:07.300] . If
{timeScale:600} , then this is ipreted to be 7.5 seconds (7 + 300/600). If

{timeScale:400} , it would be 7.75 seconds (7 + 300/400).

{textBox: top , left , bottom , right }

Used to set the dimensions and location of the textBox relative to the other
visible tracks. Example: {textBox:0, 0, 80, 320} will draw the text in
an 80-pixel-high by 320-pixel-wide box at the the top left of the movie window.

{anti-alias: onOrOff }

Display text anti-aliased. While anti-aliased text looks nicer, it incurs a
significant performance penalty.

{keyedText: onOrOff }

Render text over the background without drawing the background color. This
technique is otherwise known as "Masked Text."

{doNotDisplay: onOrOff }
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QuickTime will not display the text after {doNotDisplay:off} . Kind of
like commenting text out. To turn text display back on, use

{doNotDisplay:on}.

{doNotAutoScale: onOrOff }

QuickTime will not scale the text following {doNotAutoScale:off} if the
track bounds increase. To re-enable autoscaling, use

{doNotAutoScale:on}.

{clipToTextBox: onOrOff }

Clips to just the text box. (This is useful if the text overlays the video, more of
the video will be displayed during shorter text samples)

{useMovieBackColor: onOrOff }

Use the backColor of the movie instead of its own.

{shrinkTextBox: onOrOff }

Recalculates size of the textBox parameter to just fit the given text and stores this
rectangle with the text data.

{scrollDelay}

{scrollDelay: 600} will cause subsequent text to be delayed one second
(if the movie has a timescale of 600) before beginning to scroll. This only works

when {scrolling:on} has been specified.

{ scrollIn: onOrOff }

Scrolls the text in until the last of the text is in view. This flag is associated with
the scrollDelay parameter.

{scrollOut: onOrOff }

Scrolls text out until the last of the text is out of view. This flag is associated with
the scrollDelay parameter. If both scrollIn and scrollOut are set, the text is

scrolled in, then out.

{horizontalScroll: onOrOff }
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Scrolls a single line of text horizontally. If the horizontalScroll flag is not set,
then the scrolling is vertical.

{reverseScroll: onOrOff }

If set, scrolls vertically down, rather than up. If not set, horizontal scrolling
proceeds toward the left rather than toward the right.

{continuousScroll: onOrOff }

New samples will cause previous samples to scroll out (scrollIn and/or scrollOut
must also be set for this to take effect).

{flowHorizontal: onOrOff }

Lets horizontally scrolled text flow within the text box. This behavior contrasts
with letting text flow as if the text box had no right edge.

{hilite: firstcharacter , lastcharacter }

Usedfor hiliting text. The parameters are first and last character to hilite in the
text that follows. Example "{hilite: 11, 14} This is a text

track" hilites the word 'text' in "This is a text track" sample.

{hiliteColor}

Use this to change the color used in highliting. The order of the parameters is red,
green, blue. Example: {hiliteColor:35000, 0, 0} sets the hilite color

to a shade of red.

{inverseHilite: onOrOff }

Use inverse hiliting rather than hilitecolor .

{dropShadow: onOrOff }

Support true drop shadows. Using SetTextSampleData, the position and
translucency of the drop shadow is under application control. Not the same as

{shadow}.

{dropShadowOffset}
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{dropShadowOffset: 3, 4} will offset the text shadow 3 pixels to theright and 4
pixels down. Only works when {dropShadow:on} has been specified.

{dropShadowTransparency}

Pass in a value between 0 and 255. Changes the intensity of the drop shadow.
Example: {dropShadowTransparency: 127}

To Learn More

The QuickTime Player documentation has additional information on how to import and export
text tracks using QuickTime Player on a Macintosh and under Windows .
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Auto URL: HREFTrack Controlling Frame
Contents

The residents of Hong Kong are rarely, if ever, mistaken for their kin on the
Chinese mainland.

This is a demo of a QuickTime movie with a special text track called an "HREFTrack." The
HREFTrack specifies, at certain times during the movie, which text to display in the frame to the
right of the movie. Ordinarily, of course, the text track would be hidden.
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Adding HREF Text Tracks with QuickTime Player

Introduction

This workshop shows you how to take a movie and create and add a special text track -
an HREFTrack - that loads additional information into a frame at specific times during
the movie.

You can also use this workshop to learn how to create a regular, visible text track.
Regular text tracks can be creatively formatted, so after you've reviewed this document
you'll want to look at Text Descriptors and Time Stamps for information on how to style
your text tracks.

But first, look at an example of the kind of page this workshop will show you how to
create.

You may also want to look at the syntax for the HREFTrack.

Create a base text track

The first step is to create a text-descriptor document with a start and end time code for your movie.
The best way to do this is to let QuickTime Player do most of the work for you. Follow these steps:

Using Simple Text (or WordPad on the PC), create a text file with anything in it. In this
example, the file contains the words "some text"

1.  

Import the file into QuickTime Player. It will be converted into a short movie.

Text imported into a movie by QuickTime Player

2.  

Copy the first frame of the movie to the clipboard (Command-C on Mac, Control-C on
Windows)

3.  

Open the movie you plan on adding the text track to.4.  

Go to the beginning of the movie and choose Select All from the Edit menu (Command-A on
Mac, Control-A on Windows).

5.  

Hold down the Shift and Option keys (Shift-ALT on the PC) and pull down the Edit menu in
QuickTime Player. Select Add Scaled. (If Add Scaled does not appear in the menu, try again.
Make sure you are holding both keys down before you click on the menu).

6.  
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Chose Export... from the file menu and select Text to Text in the popup in the dialog.7.  

VERY IMPORTANT: Click the Options button in the dialog and click the Save Text,
Descriptors, and Time option. Now select 30 from the pop-up menu next to Show Fractions of
a Seconds as 1/__. Finally, click OK to dismiss the dialog.

The export options dialog for export to text

8.  

Click the Save button and choose a name for the file.9.  

Editing the Text Descriptor File

Exporting text from QuickTime Player using the Save Text, Descriptors, and Time
option creates a text-descriptor document. You will need to edit to insert your own
interesting times and actions that should occur at those times. (To help you understand
the document you're about to edit, you may want to review information at the beginning
of Text Descriptors and Time Stamps .)

The next step is to edit the file and add new timestamps and instructions. Follow these
steps:

Using Simple Text (or WordPad on the PC), open the text file you just saved. It
should look something like this:

{QTtext} {font:Geneva} {plain} {size:12}
{textColor: 65535, 65535,65535}
{backColor: 0, 0, 0} {justify:center}
{timeScale:30}
{width:160} {height:16}
{timeStamps:absolute} {language:0}
[00:00:00.00]
Some text

1.  
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[00:00:01.00]
[00:00:30.28]

You can delete the two lines:
Some text
[00:00:01.00]

What you are going to do next is use QuickTime Player to determine the times
when you want things to happen and use Simple Text (or WordPad on the PC) to
enter those times into the text file, in between the start and ending time codes.

2.  

Return to QuickTime Player and play or scroll the movie until you locate the first
frame that you want to attach a command to. Choose Get Info and then the
Movie/Time dialog:

The Movie/Time panel of the Get Info dialog

Note the time in Current Time (00:00:22.01 in this case).

3.  

Return to Simple Text and copy this time on a new line below the first time code
line ( [00:00:00.00] ). Make sure you enclose the time with square brackets.
The end of your file should now look like this:

[00:00:00.00]
[00:00:22.01] (or whatever number you copied)
[00:00:30.28] (or whatever the last time in your movie is)

4.  

The syntax to specify loading a new file at a particular time into a frame is:
A<newcontent>  T<theframename>

The A signifies to the plugin that the content that follows is to be loaded
automatically. The T indicates that rather than just replacing the movie with the
new content, the content should be loaded into a new Target frame, which follows
it. So you will also need to know the name of the frame (TEXT in this example)
and names of the HTML files you want to load into the frame at that point
(part1.htm, part2.htm and part3.htm in this example). In the example, the first file

5.  
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should be loaded into the frame right at the beginning of the movie, and the
second file to be loaded after the movie reaches [00:00:06.09]. To do this, add the
syntax for loading the frame right after the time code that you want to the action
to happen at. The first two time code lines are now:

[00:00:00.00] A<part1.htm> T<text>
[00:00:06.09] A<part2.htm> T<text>  
Note:There should be no space between the "A" and the "<" or the "T" and the
"<"
Continue in this fashion until you have found all the key time points in
QuickTime Player and copied them into the text file, adding the commands next
to each time.

The finished file might look like this:

{QTtext} {font:Geneva}
{plain} {size:9}
{timeScale:30}
{width:160} {height:32}
{timeStamps:absolute} {language:0}
[00:00:00.00]
A<part1.htm> T<text>
[00:00:06.09]
A<part2.htm> T<text>
[00:00:20.19]
A<part3.htm> T<text>
[00:00:30.28]

Note: The last line of the file must be an ending time code followed by a carriage
return (blank line). If not, your movie will not display properly.

Save your work. You're now ready for the next step.

6.  

Creating the HREF Track

First, assuming you still have QuickTime Player open, the movie you are working on
will still have the text track you added in the previous section. Since that's not necessary
anymore, you should delete it.

Select Delete Tracks from the Edit Menu. In the dialog that is displayed, click on the
Text Track (if there is more than one Text Track, select the last one) and click the Delete
button.
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The Delete Track dialog

The next step is to take the text file we just created and add it to the movie. This is
similar to how we created the first text track:

Import the text file into QuickTime Player. It will be converted into a movie.1.  
Go to the beginning of the movie and choose Select All from the File menu
(Command-A)

2.  

Copy the entire movie to the clipboard (Command-C)3.  
Select the movie you plan on adding the text track to.4.  
Go to the beginning of the movie and choose Select All from the file menu
(Command-A)

5.  

Hold down the Option key (ALT-CTL on the PC) and pull down the Edit menu in
QuickTime Player. Select Add. (When we first created the text track, we were
careful to add it to the movie scaled to last the movie's entire duration. Since we
are sure the durations match, this time we just need to add the text track movie to
the movie.)

6.  

Renaming the Text Track

Next, we need to rename the text track. The QuickTime plugin looks for a track called
HREFTrack to take control information from, but by default a text track is just called
Text Track.

To change the name of the text track, select the Text Track/General panel of the Get
Info panel and click the Change name button. Type "HREFTrack", click OK, and save
your work.
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The Track name dialog of the Text Track/General Get Info dialog

 

 

Hiding the HREFTrack

Finally, we want to hide the HREF track it so it is not visible to the user.

To do this, choose Enable Tracks from the Edit menu. Click the ON button to the left of
the Text Track to turn it off. This hides the track from the user but does not prevent it
from being used.

The Enable Tracks dialog

Creating the Frame HTML

Since this example displays the narrative text to a movie in a separate frame, the HTML
code for the frames is defined in the main page. Covering frame HTML is beyond the
scope of this document, so we suggest you look at Netscape's "Frame Basics"
documentation.
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For those of you who are familiar with frames (or simply interested), here is the main
frameset for the frames used in the example:

<HTML><HEAD>
<TITLE>Auto-URL Demo</TITLE>
</HEAD>

<FRAMESET Rows="120,220,*" FRAMEBORDER="0"
BORDER=0 >

<NOFRAMES> <BODY BGCOLOR="#FFFFFF">

<P>This page is designed to be viewed by a browser
which supports
Netscape's Frames extension. This text will be
shown by browsers
which do not support the Frames extension.</P>

</BODY>
</NOFRAMES>
    <FRAME SRC="autocont.htm" NAME="contents"
NORESIZE SCROLLING="NO">
  <FRAMESET Cols="260,*" FRAMEBORDER="0" BORDER=0
> <BGCOLOR="#FFFFFF">
     <FRAME SRC="autopres.htm" NAME="movie"
NORESIZE SCROLLING="NO">
     <FRAME SRC="autotext.htm" NAME="text"
NORESIZE SCROLLING="NO">   </FRAMESET>
   <FRAME SRC="autodesc.htm" NAME="contents" >
</FRAMESET>
</BODY>
</HTML>

A few things to notice in the example: we use the NORESIZE and SCROLLING="NO"
tags for the frame in which the movie plays so that no scrollbar is displayed and to
prevent the user from resizing the frame. We set the ROWS= and COLS= options of the
frameset to make sure that the movie has enough room in the frame to display
completely.

Creating the HTML for the Movie Frame

The HTML for the frame with the movie inside it is straightforward:

<HTML>
<HEAD>
<TITLE>Untitled</TITLE>
</HEAD>

Apple - Products - QuickTime 

http://www.apple.com/quicktime/authoring/texttrak.html (7 of 8) [3/16/2000 2:31:07 PM]

http://www.apple.com/quicktime/samples/interactive-mm/autodemo.html


<BODY BGCOLOR="#FFFFFF">
<EMBED SRC="present.mov"
CONTROLLER=true BGCOLOR="#FFFFFF" WIDTH=240
HEIGHT=196
autostart=TRUE>
</BODY>
</HTML>

This simply embeds the movie on a white background and tells it to start automatically.
(For more information on the HTML code used here, refer to the QuickTime
Webmaster's document .)

Creating the HTML for the Targeted Frame

The targeted frame - or frames - are the frames that are referenced in a movie's
HREFTRACK. The HTML for these frames can contain anything; the important things
are that:

A file with the correct name exists for each file referenced in the HREFTrack,●   

These files are in the correct place relative to the movie that refers to them. For
example, if the HREF track specifies a file "../foo.html", then foo.html needs to be
located one level up from the movie in the directory structure.

●   

Overview | Specification | Showcase | Authoring | Developers

 
Site Map | Search Tips | Options | Keywords

Contact Us | Privacy Notice
Copyright © 2000 Apple Computer, Inc. All rights reserved.

1-800-MY-APPLE
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